Java Installation / Error: 'Ascamso Satellite works only with Java 1.6 or newer....'

The ASCAMSO satellites are Java-based to allow performance measuring across different OS platforms. Therefore, it requires a Java Runtime Environment (JRE) version 1.6 or above installed on the computing instance.

When the satellite yields the following error message upon startup, it indicates that Java is either missing or outdated: 'Ascamso Satellite works only with Java 1.6 or newer. Please install it or update. Press any key to continue…'.

To solve this problem, install or update a current Java version onto the VM as follows:

1. Follow the link to a recent Java version: https://www.java.com/en/download/manual.jsp
2. Find the version for the target OS.
3. Follow the instruction to install a current Java Runtime Environment.

 

Install Java SDK from command line (http://www.webupd8.org/):

sudo add-apt repository ppa:webupd8team/java

sudo apt-get update

sudo apt-get install oracle-java-installer

 

Please note that the terms Java Runtime, Java Runtime Environment, JRE, Java Virtual Machine, Java VM, JVM refer to the same piece of software.

Have more questions? Submit a request

Comments